Funci贸n SI en excel 馃檲

Hola freaks! Una de las funciones m谩s usadas en Microsoft Excel, sin duda alguna, es la funci贸n SI().

驴En que consiste?

Si deseas obtener un resultado en funci贸n de una condici贸n dada, con la funci贸n si lo comprobar谩s.

Si se cumple la condici贸n te mostrar谩 el valor dado como VERDADERO y si no, te mostrar谩 el valor aportado como FALSO.

Estructura de la funci贸n

La estructura de la funci贸n consta de tres datos.

funcion-si-excel

=SI(Prueba_l贸gica;Valor_si_verdadero;Valor_si_falso)
  • Prueba_l贸gica: Obligatorio. Ser谩 la expresi贸n que deseas comprobar si es verdadero o falso.
  • Valor_si_verdadero: Opcional. Valor que mostrar谩 si la Prueba_l贸gica es verdadero. Se pueden anidar hasta 7 funciones SI. Si este valor no se rellena, devolver谩 VERDADERO.
  • Valor_si_falso: Opcional. Valor que se mostrar谩 si la Prueba_l贸gica es falso. Si este valor no se rellena, devolver谩 FALSO.

Ejemplo

Vamos a ver la funci贸n si() con el siguiente ejemplo:

Tenemos las notas de los siguientes alumnos y queremos saber esa nota a que corresponde, desde Suspenso hasta Sobresaliente.

funcion-si-excel

La funci贸n si simple, la vamos a usar para comprobar que alumnos han obtenido un Sobresaliente, y lo obtenemos con la siguiente f贸rmula (situ谩ndonos en la celda C2 y arrastrando hasta la C11):

=SI(B2>=9;"Sobresaliente";"")

De esta manera 煤nicamente vamos a visualizar aquellas notas que correspondan a Sobresaliente.

Funci贸n SI anidada

Pero vamos a complicarlo un poco m谩s anidando funciones SI(). Vamos a continuar con los Notables:

=SI(B2>=9;"Sobresaliente";SI(B2>=7;"Notable";""))

Seguimos con el Bien:

=SI(B2>=9;"Sobresaliente";SI(B2>=7;"Notable";SI(B2>=6;"Bien";"")))

Y finalizamos con el Suficiente, para los que sacan un 5. Si no cumple ninguna de las condiciones anteriores, la nota ser铆a Suspenso.

=SI(B2>=9;"Sobresaliente";SI(B2>=7;"Notable";SI(B2>=6;"Bien";SI(B2>=5;"Suficiente";"Suspenso"))))

Al incluir en la celda C2 la f贸rmula anterior y arrastrar hasta la C11, obtendremos la descripci贸n para cada nota.

El resultado tendr铆a que coincidir con el que te muestro a continuaci贸n:

funcion-si-excel

Si quieres sumar valores cuando se produzca una condici贸n debes usar la funci贸n sumar.si()

Si por el contrario, quieres contar celdas cuando se de una condici贸n concreta, debes usar la funci贸n contar.si()

Espero que te haya sido de 煤tilidad.

Si tienes alguna duda, por favor, deja un comentario!!

Autor entrada: Javi de Excelfreak

Deja un comentario