Función buscarv excel

¿En que consiste la función buscarv?

La función buscarv en excel tiene la finalidad, como indica la “v” en realizar una busqueda vertical en un rango de datos.
Con ella comprobamos si el valor buscado existe en ese rango seleccionado.

Se podría decir que nos encontramos ante la función de excel más usada, pero si no llegas a entender bien su estructura puede costar más de la cuenta.

Estructura de la función

La estructura de la función buscarv requiere 4 datos.

A continuación te desgloso el contenido de cada uno de ellos:

buscarv_argumentos
=BUSCARV(valor_buscado;Matriz_buscar_en;Indicador_columnas;Ordenado)

Para facilitaros la comprensión del buscarv vamos a usar un ejemplo práctico:

Tenemos la lista de alumnos de una clase con sus notas del examen de matemáticas
buscarv_notas_matematicas

Y vamos a preparar un buscador para obtener el nombre y la nota del examen únicamente insertando el identificador

funcion_buscarv_excel

De esta manera al ir variando el identificador el nombre del alumno y la nota variarán automáticamente.

    • VALOR_BUSCADO: (obligatorio) Este es el valor que queremos encontrar en el rango de datos que hemos selecionado.A la hora de introducir el valor hay que tener en cuenta las siguientes opciones:
      • Podemos insertar una palabra, siempre tendrá que ir entre comillas dobles (“), de otra manera el resultado será erróneo.
      • Podemos insertar un valor numérico, no debe ir entre comillas, de otra manera el resultado será erroneo.
      • Podemos hacer referencia a una celda, irá sin comillas, de otra manera no reconocera el valor de la misma.

      En el caso del ejemplo el valor buscado es el identificador.

      Con este valor vamos a obtener tanto el nombre del alumno/a, como la nota obtenida en el examen de matemáticas.

      Para obtener dicha información el buscarv comenzaria de la siguiente manera:

      =BUSCARV(G3;...)
      

      porque el dato que tenemos es el identificador de cada alumno que vamos a insertar en la celda G3

    • MATRIZ_BUSCAR_EN: (obligatorio) Este es el rango en el que queremos realizar la búsqueda.La estructura debe ser la siguiente:
      CeldaOrigen:CeldaFinal

      ¡IMPORTANTE! La celda origen debe coincidir con la columna del datos del cuál quieres buscar

      En el caso del ejemplo para buscar el nombre del alumno el rango sería el siguiente:

      =BUSCARV(G3;$B$3:$C$11;...)
      

      Sin embargo, si queremos obtener la nota del alumno el rango sería:

      =BUSCARV(G3;$B$3:$D$11;...)
      

      Recomendación: Para evitar que al mover la fórmula a otra celda, las celdas de la misma varíen, es recomendable fijarlas con el símbolo de dolar ($) de la siguiente manera:

      =BUSCARV(valor_buscado;$A$2:$B$10;Indicador_columnas;Ordenado)
      

      Si te fijas, hay 4 símbolos de dolar, esto es porque la celda la encuentra buscando la columna y la fila, por lo que debes fijar tanto la columna como la fila para que esa celda no varíe dentro de la fórmula.
      Y esta operacion hay que realizarla tanto en la celda origen como en la celda final.

    • INDICADOR_COLUMNAS: (obligatorio) Este valor indica el número de columna del que queresmos obtener el resultado. Siempre debe ser numérico.

      Para obtener el nombre del alumno, hay que contar el numero de columnas partiendo desde el origen del rango seleccionado; en este caso 2

      =BUSCARV(G3;$B$3:$C$11;2;...)
      

      Sin embargo, si queremos obtener la nota del alumno el rango sería:

      =BUSCARV(G3;$B$3:$D$11;3;...)
      
    • ORDENADO: (opcional) Con esta condición le indicamos el tipo de busqueda que va a realizar.
      Puede ser una búsqueda exacta indicando FALSO o una busqueda aproximada indicando VERDADERO.
      Al ser opcional, si este campo lo dejamos vacío, el valor por defecto que sería VERDADERO.

      Tanto para obtener el nombre del alumno, como la nota del examen, el valor va a ser el mismo: FALSO

      =BUSCARV(G3;$B$3:$C$11;2;FALSO)
      

Autor entrada: Javi de Excelfreak

Deja un comentario