Funci贸n BUSCARV excel 馃敟 – Buscar en una columna

Hola Freak! En el siguiente post vamos a ver como y en que momento usar la funci贸n buscarv en excel.

驴En que consiste la funci贸n buscarv?

La funci贸n buscarv en excel tiene la finalidad, como indica la “v” en realizar una busqueda vertical en un rango de datos.
Con ella comprobamos si el valor buscado existe en ese rango seleccionado.

Se podr铆a decir que nos encontramos ante la funci贸n de excel m谩s usada, pero si no llegas a entender bien su estructura puede costar m谩s de la cuenta.

Estructura de la funci贸n

La estructura de la funci贸n buscarv requiere 4 datos.

A continuaci贸n te desgloso el contenido de cada uno de ellos:

buscarv_argumentos
=BUSCARV(valor_buscado;Matriz_buscar_en;Indicador_columnas;Ordenado)

Para facilitaros la comprensi贸n del buscarv vamos a usar un ejemplo pr谩ctico:

Tenemos la lista de alumnos de una clase con sus notas del examen de matem谩ticas
buscarv_notas_matematicas

Y vamos a preparar un buscador para obtener el nombre y la nota del examen 煤nicamente insertando el identificador

funcion_buscarv_excel

De esta manera al ir variando el identificador el nombre del alumno y la nota variar谩n autom谩ticamente.

    • VALOR_BUSCADO: (obligatorio) Este es el valor que queremos encontrar en el rango de datos que hemos selecionado.A la hora de introducir el valor hay que tener en cuenta las siguientes opciones:
      • Podemos insertar una palabra, siempre tendr谩 que ir entre comillas dobles (“), de otra manera el resultado ser谩 err贸neo.
      • Podemos insertar un valor num茅rico, no debe ir entre comillas, de otra manera el resultado ser谩 erroneo.
      • Podemos hacer referencia a una celda, ir谩 sin comillas, de otra manera no reconocera el valor de la misma.

      En el caso del ejemplo el valor buscado es el identificador.

      Con este valor vamos a obtener tanto el nombre del alumno/a, como la nota obtenida en el examen de matem谩ticas.

      Para obtener dicha informaci贸n el buscarv comenzaria de la siguiente manera:

      =BUSCARV(G3;...)
      

      porque el dato que tenemos es el identificador de cada alumno que vamos a insertar en la celda G3

    • MATRIZ_BUSCAR_EN: (obligatorio) Este es el rango en el que queremos realizar la b煤squeda.La estructura debe ser la siguiente:
      CeldaOrigen:CeldaFinal

      隆IMPORTANTE! La celda origen debe coincidir con la columna del datos del cu谩l quieres buscar

      En el caso del ejemplo para buscar el nombre del alumno el rango ser铆a el siguiente:

      =BUSCARV(G3;$B$3:$C$11;...)
      

      Sin embargo, si queremos obtener la nota del alumno el rango ser铆a:

      =BUSCARV(G3;$B$3:$D$11;...)
      

      Recomendaci贸n: Para evitar que al mover la f贸rmula a otra celda, las celdas de la misma var铆en, es recomendable fijarlas con el s铆mbolo de dolar ($) de la siguiente manera:

      =BUSCARV(valor_buscado;$A$2:$B$10;Indicador_columnas;Ordenado)
      

      Si te fijas, hay 4 s铆mbolos de dolar, esto es porque la celda la encuentra buscando la columna y la fila, por lo que debes fijar tanto la columna como la fila para que esa celda no var铆e dentro de la f贸rmula.
      Y esta operacion hay que realizarla tanto en la celda origen como en la celda final.

    • INDICADOR_COLUMNAS: (obligatorio) Este valor indica el n煤mero de columna del que queresmos obtener el resultado. Siempre debe ser num茅rico.

      Para obtener el nombre del alumno, hay que contar el numero de columnas partiendo desde el origen del rango seleccionado; en este caso 2

      =BUSCARV(G3;$B$3:$C$11;2;...)
      

      Sin embargo, si queremos obtener la nota del alumno el rango ser铆a:

      =BUSCARV(G3;$B$3:$D$11;3;...)
      
    • ORDENADO: (opcional) Con esta condici贸n le indicamos el tipo de busqueda que va a realizar.
      Puede ser una b煤squeda exacta indicando FALSO o una busqueda aproximada indicando VERDADERO.
      Al ser opcional, si este campo lo dejamos vac铆o, el valor por defecto que ser铆a VERDADERO.

      Tanto para obtener el nombre del alumno, como la nota del examen, el valor va a ser el mismo: FALSO

      =BUSCARV(G3;$B$3:$C$11;2;FALSO)
      

Si tienes algunda duda al respecto, deja tu pregunta en el foro

Un saludo Freaks!!

Autor entrada: Javi de Excelfreak

Deja un comentario