Función SI en excel

¿En que consiste?

Si deseas obtener un resultado en función de una condición dada, con la función si lo comprobarás.

Si se cumple la condición te mostrará el valor dado como VERDADERO y si no, te mostrará el valor aportado como FALSO.

Estructura de la función

La estructura de la función consta de tres datos.

funcion-si-excel

=SI(Prueba_lógica;Valor_si_verdadero;Valor_si_falso)
  • Prueba_lógica: Obligatorio. Será la expresión que deseas comprobar si es verdadero o falso.
  • Valor_si_verdadero: Opcional. Valor que mostrará si la Prueba_lógica es verdadero. Se pueden anidar hasta 7 funciones SI. Si este valor no se rellena, devolverá VERDADERO.
  • Valor_si_falso: Opcional. Valor que se mostrará si la Prueba_lógica es falso. Si este valor no se rellena, devolverá FALSO.

Ejemplo

Vamos a ver la función si() con el siguiente ejemplo:

Tenemos las notas de los siguientes alumnos y queremos saber esa nota a que corresponde, desde Suspenso hasta Sobresaliente.

funcion-si-excel

La función si simple, la vamos a usar para comprobar que alumnos han obtenido un Sobresaliente, y lo obtenemos con la siguiente fórmula (situándonos en la celda C2 y arrastrando hasta la C11):

=SI(B2>=9;"Sobresaliente";"")

De esta manera únicamente vamos a visualizar aquellas notas que correspondan a Sobresaliente.

Función SI anidada

Pero vamos a complicarlo un poco más anidando funciones SI(). Vamos a continuar con los Notables:

=SI(B2>=9;"Sobresaliente";SI(B2>=7;"Notable";""))

Seguimos con el Bien:

=SI(B2>=9;"Sobresaliente";SI(B2>=7;"Notable";SI(B2>=6;"Bien";"")))

Y finalizamos con el Suficiente, para los que sacan un 5. Si no cumple ninguna de las condiciones anteriores, la nota sería Suspenso.

=SI(B2>=9;"Sobresaliente";SI(B2>=7;"Notable";SI(B2>=6;"Bien";SI(B2>=5;"Suficiente";"Suspenso"))))

Al incluir en la celda C2 la fórmula anterior y arrastrar hasta la C11, obtendremos la descripción para cada nota.

El resultado tendría que coincidir con el que te muestro a continuación:

funcion-si-excel

Si quieres sumar valores cuando se produzca una condición debes usar la función sumar.si()

Si por el contrario, quieres contar celdas cuando se de una condición concreta, debes usar la función contar.si()

Espero que te haya sido de útilidad.

Si tienes alguna duda, por favor, deja un comentario!!

Autor entrada: Javi

Deja un comentario